Shattering, laggy geometry collection after updating from 5.1.1 to 5.2.0

Hey all,
After I upgraded my project to 5.2 the geometry collections pieces acts really laggy which wasn’t a problem in 5.1, unfortunately I can’t downgrade my project.

Do you have similar problem with 5.2
Is there any other solution for the laggyness?

Thank you.

Hey there @z3u5! Welcome back to the community! Are newly generated geometry collections also having performance issues as well as the migrated ones? Are fresh 5.2 projects having similar issues with geometry collections performance?

Hey @SupportiveEntity ! Thanks for the quick reply. Yes also newly generated geometry collections are acting the same way, unfortunately updating from 5.2.0 to 5.2.1 didn’t fixed the problem.

Maybe it uses half the frame rate to gain some physics performance?
I didn’t find any settings or reference to change this.

Here’s an example:
GeometryCollection521

Hrm, I’ve been unable to replicate this issue. As you say it kind of looks like the physics is ticking slower, but the only usual method to do that would be handling their ticks async and at their own speed, though you’d have to do that manually.

Is this for smaller fracture counts as well?

Hey, the issue only appears when there’s a more complex geometry colletction, or there’s a lot more simple geometry collections available on the same level.

On smaller fracture counts there’s no problem. I acchieved to replicate the problem with more fractrure levels/more fracture counts.

Ahhh that makes sense, it’s looking like the physics tick itself is taking time to process but localized to the collection. I’ve got to do a bit of digging to see if it’s just maxing out it’s physics thread or if this is throttling as not to damage performance outside of it.

So I’ve made a workaround to completely avoid using chaos destruction: I simply made an actor blueprint with a static mesh in it, and in the hit event I added a procedure to despawn the static mesh, and spawn all the predefined prefabricated shattered meshes giving them physics enabled.

I’m not sure about the performance hit for this workflow, but I have much more control over the breakable objects (like I can add sound for the event, enable despawn the pieces after a defined time for each piece, etc…) For now this works great and I have no laggy pieces.

If you happen to found a solution for the Chaos destruction laggyness I’m still curious, as I may have to switch back to it at a certain point.

Thank you.

1 Like

Setting the Geometry Collection tick to Post Physics seemed to fix these weird lag issues for me, in 5.2.

4 Likes