Shadows only high res when object is moved?

I’m having trouble creating high resolution shadows with my 2 sided textured planes,

when the scene lighting is baked they go all blocky as if the lightmass was high, but they come out really bad, now the weird thing is that when I move the planes they create high resolution shadows, why is this and how could I change it so that they stay high res?

Any help is much appreciated.

Fixed it.

To solve this problem.

Change the Static light level scale in the world setting panel to something around 4.

On your Directional Light Source change the Dynamic Shadow Distance to something around 2500.