Shadows not matching up with corners?

Updated Question
I’ve been using blender to create my meshes and export to fbx. When I import them I get a message saying “No smoothing group information was found in this FBX scene. Please make sure to enable the “Export Smoothing Groups” option in the FBX Exporter plug-in before exporting the file.” Blender doesn’t seem to make use of smoothing groups, and there is no level of control for them in the exporter.

The mesh appeared in the editor as though it was just fine so I kept using it to see what would happen. When I finally got my walls put together, I noticed the corners of objects that are supposed to meet the shadow don’t. I even tested this with a new project. I put a bsp on the ground and I get decent shadows, but the corners still aren’t matching up.

This doesn’t look like a Smoothing Group issue, but rather that you need to increase your lightmap resolution. The default resolution is 32, and if this is a single mesh you will need a higher resolution. Try something around 128, 256, or 512. This should be enough, but you may also need to go up to 1024. Anything much higher than that and you would probably want to break the mesh up into smaller chunks to use the Lightmap UV space effectively with a lower resolution.

You can find some helpful tips and basic troubleshooting on our wiki guide: A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums

As far as the warping goes that fixed it, but the corner being cut off just seems to get sharper instead of going away.

The shadow is perfectly straight, but the corners of objects aren’t lined up with the shadow. Also part of the penumbra is slightly ahead of the object.

Depending on the size of the floor mesh this is expected to some degree as you would need to increase the lightmap resolution of the floor mesh to accommodate its size. You can use the view mode for Lightmap Density to compare mesh lightmap sizes relative to other meshes in your scene.

You can further refine this some by opening the Project Settings > Rendering > Distance Field Penumbra Size (Not to be confused with the dynamic DF soft shadows) > adjust the penumbra to be smaller. Default is 0.05.

Static Lighting Penumbra comparison

Floor Mesh LM res of 1024

Penumbra size of 0.5

Penumbra zie of 0.01