Shadows disappear with increased camera distance

Just playing with the shadow Bias setting a good value is: 0.05 This value can be found in the light properties

Where I change this values???

r.Shadow.FadeResolution - controls how big the light has to be on the screen before it starts to fade out.

  • Default Value: 64
  • Can lower this value to keep shadows from fading out at further distances

r.Shadow.MinResolution - controls how big the light has to be on the screen before it finishes fading out, at which point it no longer has cost.

  • Default Value: 32
  • Lower values seem to increase shadow visibility.

r.Shadow.TexelsPerPixel - Causes a higher resolution to be assigned and then it should fade out less aggressively

  • Default Value: 1.27324
  • Can increase this value to improve shadow rendering visibility & quality

r.Shadow.RadiusThreshold

  • Default Value: 0.03
  • A lower value of 0.02 or 0.01 greatly increases shadow visibility at far camera distances (seems to have the most impact of all the console commands).

In console.
’ ~ ’ key.

through Execute Console Command in blueprints

Does not resolve this issue.

1 Like

This might help for some.

Select DirectionalLight actor, under Cascade Shadow Maps parameter, set the Shadow Dynamic Distance MovableLight to higher values.

3 Likes

Greetings @BrAvZdGrEaT !

We see that this is your first time posting in our forums! :medal_sports: We welcome you to the Unreal Engine community with open virtual arms! Thank you so much for your contribution to this thread. It is members like you that keep our forums going strong! :muscle:t4:

This…this right here! ^^ Worked like a charm. No code necessary, no console command. Thank you!

What exactly did help you?