Shadows and light leak problem

Hi, question :slight_smile: I have a strange problem: I build my lighting and everything finally looks ok pic 1, but after some times due strange reason (tomorrow after reopen file or after making sequencer cinematic etc. ) on walls I have strange kind of low res shadows pic 2, I thought it is because of directional lights but I deleted them and same problem occurs. Any ideas, drivin me crazy…

Definitely a memory streaming poolsize problem. Try increasing it with this command :

r.Streaming.PoolSize xxxx (xxxx is the amount of vram you want to allocate, default is something like 1000 or 1gb. I use 3000)

Should solve your problem. Being there done that hehe.

Yes, that solved problem :slight_smile: Let me know how smart is to disable texture streaming? how much does that affect overall scene, and should buying 8GB graphic help using insane amount of textures without any problems in that field :slight_smile: Thanks alot once again!

The more vram the better of course. You could disable texture streaming but the initial loading time can be a bit longer.

texture streaming can be a good thing. Some textures are looking very noisy from the distance and using a smaller version of them makes them look better. I may be wrong but I would not recommend turning off texture streaming. You need to be smart about texture sizes and light map sizes. Using extra large textures and ultra high lightmap resolutions will not always have the best result.
Also make sure that every texture in the scene has a power of 2 size, eg 2048x2048 or 512x512 or 1024x512 and so on. Non power of 2 textures will never stream and you might end up having light map textures stream instead. Modern video cards have a lot of memory but you can still fill it up with potentially useless data and may run out of memory in large scenes.