Download

shadow not at edge of object

I am not sure what I may have changed, but i don’t remember my shadows doing this. Any idea why the shadow isn’t starting at the base of the object edge?

Try using moveable lights…

Yea I tried static, stationary, moveable. Moveable so far is closest, I been messing around with everything, but when i get it close to the edge, then the other shadow aspects go wonky. shadow bias looks bad everywhere else, when i get it sharp, the distance from edge moves away. or the distance fade looks all nasty. this is tricky and annoying AF

Im trying out going fully dynamic lights following a tut on YT. ::CROSSES FINGERS::

So I started the Dynamic Lights. I haven’t been able to “fix” the shadow, edge, not I am experiencing something else. I am not seeing this happen to anyone else even on the tutorials, where the screen goes darker or brighter in areas. Now I set the min and max brightness to 1.0. so the auto exposure in the Post Process shouldn’t be doing anything, but yet there is still this darkening and lightening in corners.

Any Idea?

Here is a video:

one step forward 100 steps back =P

Weird also now when I run the game in split screen the whole thing is a mess… the bottom split doesnt look anything like the top, and the top screen just flickers everything crazily…

Have you got auto exposure turned on in the project settings? Definitely turn that off…

Nope, Auto Exposure is off. this is my exposure settings there

This lighting thing is really confusing me.

Ive watched most every epic video on the topic of dynamic lights. i have probably messed with every setting and nothing makes sense to what I am getting as a result.

im really trying to understand how to handle shadows.

it seems to be very fleeting right now. several things don’t make sense at all.

No clue where this “auto adjusting” to the I am guessing the AO is happening in the same area but just moving in and out is coming from. Why i cant get even shadowing inside buildings. Think fortnite interiors. the interiors have super dark ceilings while the walls and floor look “lit”

also why my masked planes with have this weird moving white bar on them in the shadows.

here is a more descriptive image

It’s always tricky to tell what’s going on from a distance like this.

If you want it brighter inside, increase the skylight.

If you think you’ve tweaked something and can’t recall what, make a new project and then migrate this level to it. Replace the lights with fresh ones and see what you get…

Thanks! It may or may not be the lights, could be a world setting maybe. When I increase the skylight it “fixes” the interior how I want, but then the ceilings stay dark. almost like the only things casting shadows are objects totally horizontal and object going vertically on Z light passes through them. but then when I turn skylight shadows OFF i get no Distance Fields and no AO… ill try doing the new project thing. thanks!

here is what the increased skylight output intensity does… ceilings stay almost blacked out

Weird. what in the hell is Lower Hemispher?

I adjusted it and this happened