Shadow map weird behaviour

Hi all,

I encounter some strange issue in my scene after building the lighting. Non-sense variation of shadows can be spotted on the meshes. It looks like something cast shadows randomly on the surfaces. I’ve checked my lightmap coordinates and everything is ok and the resolutions are quite high (between 512 and 1024). On Shadow maps the stranges shadows can be easily spotted.

What can be the reason of such behaviour ? I wonder if the IES are the reason of the bugs because IES seem to have been modified since the 4.22 version.

If anybody have any suggestion i would be more than happy ! :wink:



Can you post a screenshot of your lightmap uv’s? You are sure you got the settings right?

Hi S-Dot,

I made another build tonight and the results are the same. FYI i attached my UV and lightmass properties for a cushion. As you can see the parameters seem to be all right…

I’m out of idea.

Thanks in advance,


Does it give you any errors after building lighting?

Try setting the destination lightmap index to 1. Then hit apply changes further down in the build section. Scroll down to the general section and set the lightmap coordinate index to 1 there. Then build lighting again. Preview quality should be good enough to see if that fixed it. You can do a proper build if the preview looks ok-ish.

Best keep the 2 resolutions the same. You got min res 256 and actual res 512. Which isn’t causing any problems but I would always try to keep the settings the same. For a small object like this 128 should be enough.

I have to ask: Do you have multiple cushions attached as one mesh? That would explain it. Each UV chart needs to be unique in the lightmap. Even if the uv layout is exactly the same every cushion receives different light. The above change will fix this.

Btw I thought IES only works in dynamic lights. Haven’t used it for a while.

Hi everybody,

Thank you two for your answers. I figured out how to fix the problem. The cause was the rectangle light placed on the ceiling to enhance the overall lighting of the scene. The area shadows were turned off. Since i activate the option, the bugs disappeared.

Thanks again,