Download

Shaders not compiling correctly in HTML5

Hello everyone !

I’m trying to make the Archviz scene from Koola working on HTML5 the compiling works just fine but when I play it the tree made from speedtree and the environments are in black and I don’t get why. You can see this here : http://denishenon.free.fr/Lightroom-HTML5-Shipping.html (open it in Firefox)

I hope somebody can help me ! Thanks in advance guys !

Denis

I can’t be certain, but I suspect that the specific shaders are not compatible with GL ES2

But which “option” of the shaders is not compatible? I don’t see anything different from one which is working to another which is displaying black.
Thanks for your answer I’ll dig that :smiley:

Well I have not looked at the demo itself. I did take a quick look at your link. Since you mentioned one of the objects as the tree, I suspect that is using one of the Subsurface materials, in which case that will not work in HTML5. As for the others, not entirely sure.

Hey thanks for your answer!
Ok I will remake another system for the tree shaders but how come that the “environment” (sky, sun etc) Is just showing black is it also a part of some subsurface material? (a part for the sun, a part for the sky?). I’m still at work but I will have a look at this tonight!

Thanks again

hmm… Okay so I downloaded the demo and took a look. Dont see anything out of the ordinary. But after taking another look at the HTML5 demo. There seems to be a serious depth issue going on. Things are rendering in the wrong order. Like whole walls are missing from certain views. Now that could just be my version of Firefox. But if not, then that would explain why things don’t look right.

I don’t get it do you mean you don’t have the holes for the windows like I have on the left of my screenshot?
15312d366e0de2aa1b5fa9b4946992fa1d368512.jpeg

I have bigger issues, I don’t think I will be able to help you much further, since what I am seeing is very broken. But just to note. The cloth is also subsurface. So the tree actually has something else in it thats preventing the rendering.

3fa2eca9a6313ab678f6c71fde3687520f79c9ae.jpeg

Ouch I see I’ve tried it on some old version of firefox (not that old I think now) and it worked.
I will have a look tonight but I don’t see what this problem is !

Thanks a lot for your help Ehamloptiran ! I will post here if I find an answer!

So about the black display it seems it’s all about LOD’s or Submaterials when I put one of the tree’s shader on a single object it works.
I don’t find anything about the sky shader btw still a mystery…