Its not exactly a bug? but whenever I just open a material a bunch of shadercompileworkers spawn in my activity monitor and my fans scream. If I wait long enough UE4 will usually crash or hard freeze my machine which is way worse. Also they take over my processors. Hitting save on a material takes over 100% of my CPU time (it will even say 102% which I don’t understand…). Why does it go crazy just opening a material ? Also saving a material is very slow compared to all other saves. Is there something I can do to calm them down? I have turned off live update and statistics but I still have to save.

I am using UE4.14.1 ( it did the same in previous versions)
iMac Retina 4.0 ghz i7 and another at home which is 3. something with Sierra .

I feel like if this problem is fixed UE4 will run much cleaner and be more stable on a Mac. Right now I save allll the time due to random crashes. Not sure if they are related.

Since 4.14.1 I have had to hard restart my computer twice just today. I am making material instances and deleting unused materials and thats it… I don’t get a crash it just locks up my computer .

Can you provide me with your full ‘dxdiag’ and any crash logs you have from the crashes being reported?

Since you are fairly new to AnswerHub I am giving you a link to the general guidelines and information we request from our users when logging bug reports.

Report a Bug

This will give you all the necessary steps to follow when reporting bugs on the AnswerHub. Let me know if you have further questions or need additional assistance.


Here is a summary but how do I get the full dxdiag?
link text

So since you are working on a Mac, you won’t have a ‘dxdiag’ per say because Macs use OpenGL/Metal.

The ‘dxdiag’ stand for DirectX Diagnostics, which gives you a full rundown of your PC specifications including RAM, GPU, CPU, and other pertinent information.

In your case, you can simply go to the Apple icon on your Mac and select the ‘About This Mac’ option. IT will then give you a quick rundown of your system’s specifications. We really only need this information, as I have shown below.

macOS Sierra Specs

Let me know if you have additional questions.


ahhh ok


So I had a peer run a test on his Mac with very similar specs to your machine, and he saw some spikes in CPU usage when shaders were compiling, but once they completed compiling, the editor’s performance returned to normal without any crashes or freezing.

Unfortunately, unless we can reproduce this issue internally, we cannot move forward with the bug reporting process. I would be sure you are not running anything in the background while you are compiling shaders.

With all of this said, we do have some documentation on being able to modify the Shader Cache so you can optimize shader compilation.

Fshader Cache

Let me know if you have additional questions.


I have everything shutdown and I get that spike. Also I am not sure if its related but my project will no longer build lighting. I forced it off for now but maybe this is a related problem? I really don’t need lighting so that isn’t a problem but I don’t like things not working.

I am sorry you are having a difficult time getting things to run smoothly on your end. Was this occurring in any previous engine versions, or is this the first time you are testing Unreal Engine on your Mac?

I would definitley take a look at ways to optimize how your application runs, like reducing the Engine Scalability Settings to help improve overall performance.


I just want to show a save and what happens in the activity monitor. This also happens if I have live update enabled

Everything runs fine. I am in epic and high for everything and it runs quick except if I go to modify a material. Then my fans go crazy and usually I will get a crash soon after. I have tried lower setting on the the engine scalability but the material editor still spikes my cpu usage on my Mac. It has been the most noticeable since 4.14. In 4.13 it didn’t seem to behave that poorly. Again there might be something wrong that I did because the lighting won’t build also and I imagine lighting and materials are connect in some ways. I have converted all my materials to instances and I just avoid opening the material masters. Is there anything I can look into for getting the lighting to build again? It just gets stuck at 0% and never gets past it.

How do I do this? When I try to run a console command they all say read only!

Yeah, I would honestly delete your Saved, Intermediate, and Config folders. Be sure to make a copy of them first, but those folders/files saved references and could have a dirty or corrupted reference.

I have a feeling it is a setting or something you have enabled/disabled that is causing your Mac to spike, but keep in mind this is expected whenever you are opening a material for the first time. If it happens every time you open a material though, even ones you have already opened and precompiled, then that could be something wrong with your local DDC (Derived Data Cache).


Yes I have rebuilt it a couple times ( deleting the 3 folders ). When I make a new project it acts as you are saying. It spikes for a few seconds then calms down. If I work on a material in my project though with live update on it spikes all the time. I have very simple materials too. Is there a way to move a whole project into a new one? Ore will I just have the same problems anyways.

It is expected that you get some CPU spikes when modifying the materials when the shader begins recompiling. If you turn off live update and live nodes you will get a more steady way of editing materials. It will require you to either hit the ‘Apply’ button or the spacebar to update the changes made to the shader.

Also lowering your Engine Scalability from Epic will help overall editor performance, including compile times. In short, what you are seeing is expected and your performance shouldn’t be an issue once those materials have finished compiling. You can migrate content from your current project, but you might run the risk of needing to compile those newly migrated shaders as they have not yet been compiled for that project.

Thank you,

Ok thank you for your help. I will turn down the settings when working on materials and leave live update off.

Thank you,