Download

Shade issues

Hello, this is my first time here and I would like to thank you all for this great forum.

I’ve been reading a lot and I couln’t find a good answer for my issue, which is the following: There is a sort of bug in the visualization of shades in some corners of my model. What I did was this: I modelled a basic structure in Revit and exported it on a .fbx format to 3ds Max where I unwrapped the mesh and packed the UVs. Then I exported it on .fbx again to UE 4.5.1.

For further understanding I have attached some pictures.

Again thanks a bunch and FYI I am a beginner at this.

Looks like shadow bleeding (when you mean the black part on the 2nd picture - left doort upper right corner) -> check your lightmaps :slight_smile:

http://www.worldofleveldesign.com/categories/udk/udk-lightmaps-03-how-to-fix-light-shadow-lightmap-bleeds-and-seams.php
http://www.worldofleveldesign.com/categories/udk/udk-lightmaps-01-basics-and-important-principles-for-creating-using-lightmaps.php

Also make sure to use a higher lightmap resolution for your meshes + add a lightmass importance volume

Thanks fighter5347! Which lightmap resolution should I use?

It always depends on your mesh, but in your case something around 128 should be enough :slight_smile:

Ok, thanks.

How can I apply, scale and rotate a material on a single surface? I can´t find the surface properties section used on the tutorials of UE4 or the F5 window used in UDK.

Just select the BSP and under the “Surface Properties” in the details you can change it -> but this doesnt work with static meshes :slight_smile:

Ok, I´ll try it

Otherwise scale the texture in your material (texture coord node) or 3d program :slight_smile:

Hello, I´m having trouble with the shadows again, this time I´m using a 256 lightmap resolution and I still can´t get sharp, realistic shadows. I couldn´t find a solution on the web so I would really appreciate some help.

e2daa4f4d5450e387a1e7b670ac0743fd635af0f.jpeg

f757ce851f42ce49f7f6c631ace660a6f3d1ebea.jpeg

BSP surfaces (like your platform) use smaller numbers for lightmap resolution to get better resolution (unlike meshes). Try setting your BSP surfaces to 2 or 4.

Hi Claudiobdlv, shadowing problems you see in your scene are caused by two major reasons one is low lightmap resolution for static meshes and bsp and two shadows casted by ststionary lights are low precision even with sharp and nice looking edge. If i was you id select directional light and set radius for dynamic cascaded shadows that replace static in close proximity to the camera

Thank you. what about ray traced shadows? Which type of lighting should I use for Archviz?