Download

Several rotations in a row cause stuttering

I have a targeting system for my melee character and I’m rotating my character’s camera, head and body. Triggering the two first events is working well until I plug the third one which then cause stuttering on my camera.

If I only connect the last bloc and not the two others it works correctly so I would say the issue is that this multiple rotations are overriding each others. Do you guys have any suggestion? Thanks


Changing the Interp Speed by anything but 0 is fixing the stutter, but then my character’s body doesn’t rotate to the enemy (no idea why)

Finterp needs a constant as the target, you are sampling the current value with the look at node.

Just use the lookat node once to figure out your target, and then put that into the finterp node.

It may be a typo but I’m using “Rinterpto” here. Also, if I do that, wouldn’t my character rotate to the enemy only once? In this example the target Z value is setup only once, when I target my enemy:

Here’s my original issue:

And then after your solution:

As you may expect, the rotation isn’t updated afterward.

Rinterp, sorry :slight_smile:

Update on tick, yes, but don’t sample the current rotation in the Rinterp node.


Thanks for your help ClockWorkOcean, but still no luck, the result is camera stutters like in the first video.

Try using SetControlRotation, rather than actor rotation.

The thing is that (if I take back my original setup) this is working perfectly fine if I only connect the last block:

But as soon as “Rotate To Enemy - CAMERA” and “Rotate To Enemy - BODY” are connected together, it will cause issues. Is it because in both of them I’m setting the node “Find Look at Rotation” ?

Yes, just set one.

EDIT: Sorry, read it again. Are you also using animations? Might be quite fiddly.

In general though, you either want to use control rotation, or actor rotation. You will probably get in a muddle using both.

Also notice the options in the blueprint and character movement component which relate to this:

1 Like

That was it! “Use Controller Rotation Yaw” just needed to be activated for it to match the controller yaw rotation from my blueprint.
I never would have found this to be the problem, thank you again for the help!

1 Like