Setup splashscreen

Hey guys,

I have been trying to hook up a splashscreen/initial loading screen (not for loading purposes though) for the Gear VR.
Setting the splashscreen or the launch portraits in the project settings did not do the trick.

Am I missing something? I am starting the app on my android phone and then putting the phone into the Gear VR - I am supposed to see the splashscreen first, before entering the default game level, right?

All the parameters that in blueprint are given to AddLoadingSplashScreen can also be written in the DefaultEngine.ini file of the game (Config/DefaultEngine.ini), as shown:

(most of those parameters are optional)

[Oculus.Splash.Settings]

TexturePath=”path”

DistanceInMeters=translation (vec3)

Rotation=rotation (quaternion)

SizeInMeters=size (vec2)

DeltaRotation=delta (quaternion)

My exact parameters that work for me:

[Oculus.Splash.Settings]
bAutoEnabled=True
TexturePath=/Game/Textures/loadingScreen_gearvr.loadingScreen_gearvr
DistanceInMeters==(X=1.0, Y=0.0, Z=0.0)

where loadingScreen_gearvr is a texture located in a Textures subfolder of my content folder. Strange you need to duplicate the texture file name after the . So: loadingScreen_gearvr.loadingScreen_gearvr is no typo.
Also I’m not 100% sure if bAutoEnabled=True is required but thought it couldn’t hurt :wink:

Hey aussieburger, thank you very much for your help!

I will try it out as soon as possible, need to get my hands on another Samsung phone first. If this really works, you will have helped me immensely, as I would have never found this solution myself!

So, thanks in advance, I will keep you posted.

no problems - PS I forgot to mention: the splash screen settings you used in the project settings are for android only builds. It does not work for any of the VR platforms and they have their own settings that can be set via the defaultEngine.ini or blueprint nodes.

So if you don’t need it for the initial load you can also set and change the texture in the blueprint node: “Add Loading Splash Screen”