Setup.bat not downloading any files

Hi! I updated my engine version from 4.9.1 to 4.9.2 and it broke all my projects. I deleted all files, clone git, and run setup.bat, but see only this for 3 days…


What am i doing wrong? Try again didn’t help.
Also i have installed AndroidWorks. If i delete it, Setup.bat downloads all files fast and correctly, but after installing it need to run Setup.bat again to update dependencies for Android and it stops like that (with not 3.4GB, only ~340MB and downloading speed is also 0.00).
I intend to use ue4 to do Android and Windows projects. Before i did it easy and had no problems/errors, but not now and revert to 4.9.1 didn’t help.

Solved this problem by spamming packets to target servers.
It was routing error. I tracked all my packets to target server and they are in infinite loop in Amazon’s cloudfront network (is Epic Games holds all files there?). I started spamming ip-address of Amazon where my packet enter to loop. After 40-50 minutes i got access to target server and my downloading speed increased to 3+ MiB/s

get same problem, trying your way. But no luck. Any I other idea?

i have tried to ping Amazon’s servers - and no luck.
i have tried to traceroute it and found routing issue.
i have no idea if it have another solutions.

  1. you can try to flush route table
  2. setup proxy
  3. use another Internet connection

or maybe it isn’t connection issue

Seems, thats a windows problem. My Mac downloads files normaly.
Also, when I set proxy Chrome on windows can download, but setup.bat not

Solved using --proxy param in command line.

i have the same problem ,you can use options --threads=20
very fast :slight_smile:

Thank you so much!!! the --proxy param helped me, I was stucked on it.

How exactly do you set proxy?

How exactly do you set proxy?