Download

Settings required to do FBX Import/Export on Blender

I’m having trouble getting the correct settings to import the Epic humanoid mesh into and out of Blender. I downloaded the sample fbx hero mesh content and tried to import it into blender, but the bones are not oriented correctly. I tried several different settings, but got goofy results. Finally, I set the importer bone orientation to ‘automatic’ and the bones appear correct in Blender, but then I run into the mesh not matching the bone motion when exporting to UE4. Has someone figured what the fbx import/export settings need to be to get this to work correctly?

UE4 4.6.1
Blender 2.73

There was a Stream about importing and exporting with Blender by Epic

https://youtube.com/watch?v=Ayp1lof0RJU

and here is the thread with the pictures of the settings that were used: https://forums.unrealengine.com/showthread.php?56101-Twitch-Support-Stream-–-Blender-Animation-amp-UE4-–-Jan-13th-2015

Grrr. I tried the settings demonstrated in the links provided above and this is what I got:

http://www.roboticgladiator.com/images/hero_mess.jpg

What I did was import into Blender using the recommended settings, then immediately exported with no changes. I then tried to import into UE4. The reference pose looks fine, but the animations are a mess. The image above shows the idle animation.

Never mind. I started over from scratch and it worked this time. Not sure what the problem was.