Download

Setting up Interior - Exterior Walls

Hi all

I’m new to UE4 but I have a fair understanding with 3ds Max.
So Exporting FBX files, unwrapping UV channels etc is a new thing to me.

I’ve started a new project; it’s a small apartment I’m working on. I need some advice setting up my walls.
Below IV created 2 methods. Id would like to know which method is the best going forward when working with UE4. If there’s other methods please share.

Method 1
I created individual boxes for each wall. I use proboolean to create my door and window openings. From there i convert my boxes to editable mesh and unwrap.

c7a174e394863a0d7ae706236c8b491b96dca7ec.jpeg

Method 2
I extrude my interior splines. I also extrude my exterior spline separately (hidden in image below), but this can get tedious when creating my openings for my doors and windows.
I use the shell modifier when working with a single room but it’s not the same when working with several rooms.

Any advice would be appreciated.

Cheers
Neil

I think both methods are fine as long as your walls end up having some thickness because in unreal, the backface of any polygon is culled (performance)…and will let light pass through. I recently started to detach faces of my meshes to apply a lightmap to each face and then having higher quality lightmaps. Let’s say my wall is a big 6-faces rectangle. I wil detach the exposed parts and assign a uv unwrapping to each of them.

Same for ceiling…isntead of having the 6 faces on 1 lightmaps…I detach the visible part in the scene, assign 1 lightmap, and raise the resolution to high value, then leave the 5 other faces with low lightmap resolution since they won’t show up in-game.

Don’t be afraid to use brushes in unreal to block light if you need. Can help to reduce light leaks if you have any!

Thanks for your response heartlessphil

Heres a quick test using method 1

All my boxes are flush against each other so i dont see how light should pass.
My lightmass on all my boxes in this scene is set to 1024. But i see a hard black shadow top right… I’m not sure if thats ambient occlution taking effect.

If you have a post process volume covering your scene, you can tweak the AO there. I usually set radius to 0.1 and intensity to 0 because I prefer to tweak lightmass to give real AO, not fake AO!

Post your lightmass settings if you can. Don’t be afraid to push them high :slight_smile:

For example, I use.

Scale .8 to .9
Bounces 100
Quality 10
Smoothness .65

Oh wow! I was running default settings lol. With those tweaks it looks a lot better!
At first i thought it was the way i was modeling haha. Build time has gone up but its worth the wait :slight_smile:

3ds Max does have some tools suitable for architecture design.

Check out AEC Objects

Yea…my current project takes 11hours to build with these settings :-S (with high lightmaps res too)