Setting Up A Stop Animation

Hello. I am making a top-down game. I wanted to add a stopping animation to the character when running stops.

I set it up like; when character’s velocity reaches 0, play the stopping animation. There is a problem about this: If the player presses near the character, character goes there with this stopping animation. How can I set this right?

If I make an area around the character where can’t be pressed, it makes the gameplay bad.

I hope I was clear. Thank you.

First, for movement.
You will need blend animation as link

And then animation blueprint link

If you already did both of those then please send us a screenshot. We need to narrow down the problem list.

Yes I did those. Here are some screenshots:

Can I have a look at Blend animation?

That green dot is idle on speed of 275, you need click bottom one of ‘speed’ to put 0 as idle and increase animation per dot. Do this character able to move backward? If not then it is right.

2D is not really necessery, I could change this to 1D. It’s topdown, I don’t need backwards or strafe.

Yeah! Do that.
0 = idle
550 = max movement animation.
That what you need.

Remember, use speed vector to match with animation foot plant. Maybe your character animation is speed of 80 and it look like ice skate.

How is it gonna change the way character moves when player presses near ?

You can play with vector. Press and hold shift ( or is it ctrl?) and click drag the mouse on that grid. It’s blend animation that allow you to blend idle to run.

If you want to keep those animation, but it look iceskate? Reduce speed and put grid on as five. Drag and drop all of those animation you want in that grid.

And remember to let us know if this had been fix, tick this as answer had been resolved.

I know what a blend is but that’s not what I asked. What I asked was nothing about the speed on the blend animation.

Made another blend animation. One for idle to run, one for run to stopped.

Or you can just cheat it. Once character hit waypoint where mouse click, play animation - stop.fbx using collision trigger.

That’s what I said on the topic. When I do that, if you press close to the character, character moves around looping the stopping animation.

How can I do that if charachter just takes 1 step? Just goes there with stopping animation and if player holds the mouse button so close to the character, character goes everwhere on that animaton.

Yeah just that I was narrow down the problem as I don’t know where is the node that have problem… so I was just follow a checklist.

If the stopped animation was looping, set loop once or untick loop animation in run to stopped blend animation.


If it was me, I’ll leave it till post-production stage.

Thank you for the help.

Does anyone know?

I solved this by setting a ‘left mouse button key down’ and if it is down don’t play animation.