Setting Simulate Physics to off, breaks location of my object


So I am working on a pickup drop system. I have an object that has simulate physics on. When I pick it up and use the Set Simulate Physics node to turn it off. Then I attach the object to an object attach point I have on my pawn then I set the objects world location to there. Then I have a reverse process that turns physics back on and detaches object. All that works fine. My problem is once I try picking up the object a 2nd time, its floating in the air, or its just gone (depending on if I put my detach node on keep relative or keep world)
I have tried several things to fix this but nothing has worked

Any ideas.

Thanks, Izzy : )

also the static mesh of my pickup object is the root of the object, the attach point is parented to my camera

Yes, the static mesh is the root of the actor

I have an object that has simulate
physics on

Is the static mesh the root of this actor?

I figured it out. I was using a detach from compoient node and detaching my attach point, instead of the actor. I changed it to a detach from “ACTOR” node and put in my actual object in.