setting more then1 player doesnt show in editor windows

okay so in all other version of ue when i press play in editor and have “number of players” set to 2 it auto makes both these players visible to each other just in separate screens, now if i do the same its like these 2 players are on separate servers? even if using a fresh 3rd person project, any help?

Check inside your editor: EditorPreferences->LevelEditor->Play under the Multiplayer Options sections if the “Auto Connect to server” option is ticked.

yeh I have already checked all that before and nope makes no difference, its a issue with 4.16 because even if i start a new project i get the same issue :frowning: wat can i do