Setting master pose makes mesh invisible

First off, I know that there is a post on my problem here: Possible Blueprint Rendering Bug - Blueprint - Unreal Engine Forums … sadly there doesn’t seem to be any sort of fix. So moving on!

My problem is when I set a master pose to a skeleton component that has a specific imported mesh, the mesh simply… disappears. What’s even more strange is the fact that only a specific mesh does this, and it’s beyond my understanding of this universe.

So lets look at the facts.

  1. The order of the master pose setting
    does not matter
  2. Reimporting the mesh does nothing
  3. Putting a completely different mesh
    in it’s place works - the new mesh
    shows up
  4. Importing the mesh as a new mesh
    (new filename, fresh file) doesn’t
    work
  5. The mesh is exported exactly the
    same as all the other meshes (I use
    a program that exports to ue4)
  6. When you F8/unpossess pawn, you can
    click the character, find the mesh
    component, and find the checkbox
    “visible” - uncheck it and check it
    again, and the mesh appears.

…And I’ve done this type of thing ALL the time. So this is very strange.

Any help or questions about my problem would be appreciated!
Thanks!

Alright, I managed to figure this out… only an hour after asking this question… figures.
Here’s what I did:

It looks like when an object only has a few vertex groups compared to the number of bones in the armature it can cause this glitch. What exactly the reason is I’m not sure, and I’m not sure why it didn’t effect other meshes. Regardless, simply re-parenting the mesh to the armature in blender and choosing “With empty groups” adds all the other bone’s groups to the mesh. Re-export, and this fixed my problem!!!

So this is still a bug and should be patched, however this is a good workaround for now. At some point I might test out why certain bones don’t cause this and other bones do… one random/untested idea is the fact that the broken mesh was “vertexed” to the head, which has no child bones… while the other working meshes where attached to an arm, which had child bones. Just an idea.

Omg! Why there is no words regarding this just in a one year old topic without any votes in it… Thank you joshcamas, you saved my time for a long period ahead because I would never expect that it could be a case for my problem.

Long story short. Don’t Use full mesh to bone parenting in Blender - use Vertex groups instead!