Download

Setting Game Resolution - doesn't work in 4.23

When setting up a Level Blueprint to set a GamePlay Resolution - it’s ignored after packaging and using 4.23

you can download the project file here and test it yourself:

I followed that video tutorial:UE4 - Unreal Engine Blueprint - How to Set Video Game Resolution with Level Blueprint - YouTube
It worked when using 4.22 - but when I do the same with a project started with 4.23 → it doesn’t work.

  • Is this a bug in 4.23?
  • Or is there anything else I have to consider?

It could be a bug, but the console command still works in 4.23. I’ve seen something similar in the past the resolution was set through Event Init of Game Instance. It failed to make the necessary changes unless there was a delay. Probably for the console command systems to start up. So maybe try adding a slight delay after the Event Begin Play to check if it’s the same issue.

I had the same problem, the only solution that seems to work is the delay when you set them in the game instance or LevelBP.

I would also recommend setting the resolution (and other settings) via GetGameUserSettings -> SetScreenResolution -> ApplySettings, which will be automatically saved and then you can simply reload them at startup.

use r.setRes 600x400w or r.setRes 600x400f

Same here. Something is definitely off in 4.23. We also moved from 4.22 to 4.23 and suddenly the game is on both of my screens.

In 4.23 I added this to my Level BP but it doesn’t solve the problem:

If I start PIE it works just fine and also rewrites my GameUserSetting.ini

In Standalone it doesn’t rewrite my GameUserSettings.ini but has the correct resolution

With right click on exe an LaunchGame - closes test to packed game - something is resetting my GameUserSettings to 2880x1080 and displays that resolution. This doesn’t happen if the second screen is unpluged. But either way this BP code gets ignored, same with setRes. Even if I copy the right GameUserSettings in my config folder not in saved/config.

It’s probably a new setting / default value we are missing here.

Figured out, that my issue only happens when Steam VR is started. I’ll open a separate issue for it.

For this issue: Check your GameUserSettings or DefaultGameUserSettings

https://answers.unrealengine.com/questions/670355/packaged-game-starts-fullscreen.html

4.23 resolution issue is still ongoing…blueprint,console comand,gameusersetting are all not working. plz help.

We moved to 4.24 and that fixed the problem. I don’t think there will be a fix in 4.23.

yeah, I’m too. experiencing the problems with resolution (user settings) 4.23 and fullscreen mode if i set i ti fullscreen then change it to any other mode it may throw an error.
I am planning to move to 4.24 or 4.25 if it may come soon