Download

Setting Actor Transform Disables Collision?

Hello all! I have some objects that I’m trying position using blueprints, and using Set Actor Transform (or any function that changes it’s position or rotation) seems to remove the blueprint’s collision. Any help? Thanks! :slight_smile:

bump :slight_smile:

Without knowing exactly what is going on, this is hard to debug. This could be anything from a mis-set collision channel to a full on engine bug. We need screenshots, blueprints, whatever would help us debug your problem.

Maybe the collision box area is not moving with the actor for some reason? Check if there is an invisible colliding object in the actor’s 1st location.

I checked and the collision does not move with the actor. Really weird.

Is the collision built into the actor? Or did you spawn some sort of shape around the actor to act as collision?

It could be that the collision is not under the box in the hierarchy if so then you need to move the collision instead and the box should follow.
Please show blueprint

The collision is in the static meshes themselves. My blueprint is made up of instanced static mesh components and now derived from a class I wrote in C++.


I’m still getting the same results. Setting the actor’s transform seems to leave the collision behind.



SetActorLocation(OtherAttachmentPoint->GetComponentLocation());
SetActorRotation(FRotator(0, OtherAttachmentPoint->GetComponentRotation().Yaw, 0));


I wonder if it has to do with me using instanced static mesh components. I’m going to try switching everything to a regular static mesh component and see if that fixes it. I’ll report back here with the results.

Just tried it out, and using regular static mesh components fixes it. But Instanced Static Mesh Components don’t move the collision. :confused: