Download

Set view to sequence

Hello!

I’ve been learning to use the sequencer tool the last several days and am slowly getting a grasp on it (I have experience in After Affects). What is unclear to me is how to set the current camera to the sequence you want to play. I’ve been using the “Set View Target with Blend” node to switch to the cinematic camera being used by the sequence I will play. This does not work though with a sequence that is using a camera cut track and more than one camera. How can I simply view the sequence in the same way I do when pressing the “Lock Viewport to Camera Cuts” button on the Camera Cuts track of the sequence?

56c44ad0e73d15abe72177791002806fee82c673.jpeg

Hey there dsenter,

I know this an old post at this point… but did you ever figure a way to get this working?

I’ve been trying to get around this issue for dayyys to no avail. My setup is slightly different as I would like my Master level sequence (which consists of two shot tracks) to play when the level is first loaded as opposed to on button press, however I think we’re having the same issue. When I play my level I can see that objects in my scene that are part of my sequence are moving (leading me to believe the sequence is running), however the camera view is always just set to the last place my camera was pointing in development/perspective mode. I’ve tried the same “Set View Target with Blend” with the new target as one of my camera actors (as you did in your screenshot) and to the sequence actor itself.

I also thought maybe my primary Game Mode was affecting things (currently using FirstPersonGameMode), so I tried Un-Possessing the player controller, and even setting the Game Mode to None, all with no results.

I haven’t found an answer for this anywhere on the webs… so if you have any insight from your attempting to solve this, or if anyone else out there has any idea what’s going on, I’d greatly appreciate the help! Thanks :slight_smile:

PS: Also something odd worth noting which may or may not give a clue regarding my issue… when I view my individual shot tracks in cinematic preview view… they play correctly with the camera panning properly… however when I try to lock the viewport in my master sequence and play it from the beginning… the preview shows the correct view from the first camera shot (has the proper viewing angle, 16:9 mode, etc), but as soon as I click play the view switches to full screen and jumps to a totally different static view angle while the sequence plays. This could be an unrelated issue… but it’s also not allowing me to fully view my sequence with combined shots which is equally frustrating x_x

You shouldn’t have to call “Set View Target with Blend”. Sequencer should be properly possessing the camera you have defined in the camera cuts track. I’m not sure what could be going wrong, but if you want to point me to a project, I can take a closer look. Feel free to send me a private message.

Hi, I’m having the same problem, my camera is not in the last position of the level sequence after running the level sequence … did you get any solution ??

Thanks for the response Mr. Chen :D. I’m going to work on it for a while today and will re-post here or PM you regarding the details of my project.

CrashAngel, either way I’ll be sure to post any results I come up with so hopefully you can press on with your project as well \m/

Hey everyone,

After much fiddling I’ve finally resolved my issue. I’ll try my best to explain what was happening… however please bear with me as I’m still new to Sequencer and am not 100% sure of what all is going on.

Basically after Mr. Chen mentioned that Sequencer should be properly possessing the camera on its own I removed all the nodes for “Set View Target” and just kept a few nodes to Un-Posses my first person player controller, and then to play my master level sequence (these residing in the level blueprint). I then took a look at my shot tracks and compared them to a beginner tutorial on camera cuts (https://docs.unrealengine.com/latest/INT/Engine/Sequencer/HowTo/TracksCameraCut/) and realized that although I had added a camera within Sequencer for each of my two shot tracks, I had never actually dragged instances of Cine Camera Actor into my level (therefore they seemed to exist in sequencer, but they were not in my World Outliner. I ended up deleting my old cameras and started over by dragging new ones from Modes > Cinematic > Cine Camera Actor into my level, and then clicked +Camera in Sequencer and selected the name of the new instance.

At that point in the timeline for Camera Cuts a small preview of the camera shot appeared. When playing the sequence all of my actors would move, but only during that section with the preview would the camera properly be possessed in my Cinematic Preview. I then clicked on the handles for it and expanded it to fill the length of my entire sequence and then for the first time I was able to “Lock Viewport to Camera Cuts” instead of just the instance of the camera actor and view a full preview of the shot. I repeated the same process for my second Sequencer shot, and thereafter when opening my Master level sequence the two shots had accurate previews of the camera movement for the whole sequence (whereas before the previews were of just the first place the camera was pointing). After doing all of this and playing the level, the sequences properly played and showed from the viewpoint of my two camera cuts.

TL;DR: It appears that some combination of making sure I had actual instances of my cameras in my level (visible in my World Outliner), and then making sure that my Camera Cuts in each of my Sequencer shots were showing previews that stretched the full length of my scenes, resolved my issue so that my level could properly posses those cameras on level load without having to specify a view target in my level blueprint.

Thanks again Sir Chen! And let me know CrashAngel or whoever else if you’d like me to elaborate on anything further. Happy dev’ing! :cool:

3 years later and this thread helped me with the same issue. Except all I had to do was bind the camera cut to the CineCamera I was trying to use. I hope this helps anyone who runs into the same issue:

CineCamera.png