Set Simulate Physics on keyboard event doesn't work

Hi I don’t know what I am doing wrong here. I created an actor with a ball as a static mesh. When I connect Event BeginPlay to Set Simulate Physics the ball falls when the game starts but when I set a keyboard event to Set Simulate Physics and press Z nothing happens. Can anyone help?


I have the Blueprint set in the actor mesh. I understand I can set it in the level blueprint and it will work but I plan on having over a hundred levels and I don’t want to have to do this for every one. So is there any way I can set it up in the ball actor itself?


You need to set it up so it can control inputs:


Thanks that worked perfectly.

Glad you got it sorted…

Has anyone had problems toggling Set-Simulation-Physics in 4.10?

If its ticked inside each mesh at design time it can be disabled at runtime ok.
But re-enabling (as per above bp) does not reactivate, at least not for all meshes?

Some meshes are at the outer edges of the map, is the floating point limit at fault?