"set simulate physics" isn't working with skeletal mesh


I don’t know why, but my Skeletal Mesh is not simulating physics.
After i press G, nothing happens.
I also tried different Collision Presets and nothing is working.

In Physic Asset all simulations works fine and i also have checked on all Constraints Physic Type - Simulated

I figured it out.
I changed my physical asset name, so its ending with “PhysicsAsset” and all works perfectly.

For example.
At first it was “Enemy_1_Physic”
And now it’s “Enemy_1_PhysicsAsset”

I FIXED IT! The Physics Simulations DOESNT WORK When You Have Per Poly Collision Enabled, Just Disable IT, THEN Set Physics Simulation to True, BRU! This Can be Done On The Enemy BP Itself, So Not Need To Leave The BP Your Trying To Edit, BRU! Thank God For That!