Set Simulate Physics causes mesh deformation

Hi there,

I’m currently trying to get physical animation-based hit reactions working through Blueprints, which I’m testing by having ‘Set Simulate Physics’ applied to bones below the spine when I hold a key. I’m using a custom character imported from Blender, based on the UE4 Mannequin. I’ve got foot IK set up and working as expected, and the physics asset simulates correctly in the dedicated editor, but when I activate ‘Set Simulate Physics’, the arms of the character mesh deform in a really weird way (see screenshot comparison).


The distortion remains regardless of the animation playing - I have an idle, a walk, run and sprint, the first and last of which are animations done on the custom rig, the middle two of which are the starter content defaults.

I’ve tried disabling all collision on the physics asset (i.e., between collision meshes), and several combinations of collision settings on my mesh and capsule. I’ve also tried deleting the character’s sword (in the right hand), but without effect.

Any help would be greatly appreciated!

Interesting, have you seen:

Thanks, ClockworkOcean, that does look promising!

At the moment, I’m doing foot IK (based on Alessandro’s tutorial ( in a combination of my Anim and Character BPs, and my partial physical animation simulation entirely in my Character BP (see below), so I’m not sure how I would incorporate the Mesh Space Ref Pose into the process. I’ve also included a screenshot of my AnimBP.

When I substitute the Mesh Space Ref Pose for the cached Idle, the character reverts to T-pose while not moving. When in T-pose, the distortion problem is fixed, but returns as soon as the character begins moving again :confused:

Sorry, not sure about this. Just saw that other similar post… :-/

No worries! Always useful to get a lead :slight_smile:

Okay, so I’m not sure exactly what combination of changes fixed the issue, but these three seem most plausible:

  1. Deleted and regenerated the physics
    a. Right click on the mesh,
    select ‘Create’, then ‘Physics
    Asset’, then ‘Create and Assign’. I
    unticked ‘walk past small bones’,
    but left everything else on default
  2. Modified some of the constraints of the new physics asset to correct
    any glaring problems. I also deleted
    a few capsule colliders that aren’t
    included in the Mannequin physics
    asset, such as ‘clavicle_l’ and
    ‘_r’. I think I may have modified
    one constraint relationship, too,
    but don’t recall which.
  3. Added a ‘Set All Bodies Below Physics Blend Weight’ node after the
    ‘Set All Bodies Below Simulate
    Physics’ node in my Character BP,
    using the same bone reference, and
    with a Physics Blend Weight of 0.5.

As I say, I’m not sure which of these things was the fix, though I would assume it was regenerating and tweaking the physics asset. The mismatch between the in-editor and in-game physics simulation is the strangest thing.

Anyway, I hope that helps someone :slight_smile: