Set particle effect rotation?

I’ve tried various different ways to stop the particle effect rotating to face the camera.

I’ve locked the X and Y axis and made it rotate towards velocity, which didn’t seem to work.

I’ve set the world rotation and the relative rotation without any effect.

What’s the actual way to disable it from facing the player AND to make it always face up?

Setting it to use the velocity for rotation, with a velocity of 0,0,1 (x,y,z), didn’t work correctly.

1 Like

Make sure the particle is set to use local space in the required tab.

So I’ve set it to use local space, use the velocity as the rotation, and set the velocity to lock X and Y and +1 Z. it appears to be facing at a 45* angle for some reason?

Is there a way to force rotation other than using the velocity?

Set the rotation of the particle component or emitter actor.

Here’s what I’m seeing:


and here’s what I was expecting:


Both were taken from the same camera angle and position.

Are you sure your particle is facing the right way? In the editor and in the game?

If you’re doing align to velocity then “forward” is the +x vector, not +z.

It’s Up that I need it to go, these will be the basis of my AoE indicators for explosives etc.

I’ve tried setting, wordrotation and relative rotation on the emitter component. I’ve tried setting the emitter rotation within the blueprint and setting the sspawn rotation etc. it still looks like it;s only 45* more than it needs to be.

I’ll keep poking about, It works 100% fine with facing the camera but I don’t want it to do that.

Here’s a video of what the issue is:

1 Like