Set Members In Struct node does not work

Platform: Win7
Build: 4.4.0

Repro: attempt to update a stuct that is member of an array using the “Set Members In Struct” node. No matter what configuration I try, it will not update with new values.

Result: data is not updated.

Hi ,

I’m unsure of why your setup isn’t altering array values, I will be looking into that further. In meantime, you can set it up like I have pictured below and workaround issue.

Instead of a ‘SetMembersIn’ node, use a ‘Make’ struct node and then use an ‘Insert’ array node to overwrite old one with new array.

Thanks, TJ

For anyone running into this problem (4.4.1 as of writing), use “SetArrayElem” node instead, as “insert” actually expand your array, while SetArrayElem you have a switch to choose not to and actually overwrite index.

Thank you TJ, I’ll do it that way for now!

I can also confirm this is happening. In 4.4.3 and have lost a whole lot of time because of it :frowning: 2nd print should say True

This is still an issue.

Thank you @PenguinTD. You have solved an incredible amount of frustration I’ve dealt with today. I still can’t get set member’s in function to work at all. (unreal 4.5)

Yeah, I haven’t test 4.5 yet, but hopefully they fix this soon, otherwise it’s pita to do things properly.

I agree. Hopefully Epic will do a release soon that focuses on bug fixes, there’s a lot of little ‘gotcha’s’ floating around that have been present in last 2-3 updates.

I’m experiencing same issue in 4.5.1 updating/modifying [BP user defined Struct][1] members within an Array of Structs. I’ve approached this problem from [several configurations][2] based on above recommendations using Set Struct Members and Set Array Element Nodes. These appear to have no effect and it gets real messy with nested arrays of arrays.

My Blueprint workaround: A Structure of Arrays. I simply encapsulate two or more Arrays of an individual Data-type into Virtual Structure with some fancy Labeling and Categories/Subcategories (ie: VStructure|Array|Structname). I use macros to perform array operations (Add/Insert/Remove) on all arrays in VStruct to maintain index alignment.

more arrays more expensive. trade off, [update/modify Member with greater granularity][3] flawlessly. I’d rather be able to update a Struct Members in Array of Structs. I’d appreciate any answer/solutions to this issue.

Thank you for detailed explanation of this workaround, I appreciate it.

I do find a tad disheartening that a bug which has been around since AUGUST and hasn’t been addressed by epic yet in multiple updates since then!

These bugs can be really costly to productivity of single developers and small teams.

Does any know if this has been resolved in 4.6?

I had this problem in 4.5, and it seems to still be a problem in 4.6.

Hi everyone,

The ‘Set Members in Struct’ node works when used directly with a Struct. However you are correct, it still does not work with a Struct contained inside of an Array.

I’m sorry this fell through cracks, but I have entered it as JIRA UE-6451 in our tracking software and our developers will be looking into it further.



I found a MUCH better solution for Set Members in Struct.

short version TL;DR version: Hide Unused Pins.

For some reason, current Set Members in Struct set up will overwrite any exposed pin with default value if there is no connection to it. Simply click on node, and in node properties, uncheck box for any element you will not be using. Problem solved. I have tested this with structs, and with structs within structs. I am not sure yet but it will probably also work with Structs within arrays.


edit Since posting this original comment, I’ve confirmed that this method will work with structs nested in arrays.


That’s disappointing to hear. I’d much rather have all features that are in engine be solid before adding new shiny features.

Yes - it’s still a problem when you have Struct Array and in that array another Struct Array. Any timeline when this will be fixed? (4.7 maybe) it’s critical to have possibility to change variables in arrays…

Tested in 4.7 prev 3 - still same issue.

Fixing this issue would help me a lot too. Any clue when this one will be fixed?

Hi intoxicat3 & Tomasz,

We made sure that we updated report so that devs know more users are looking for this fix. I can’t say for sure when this will make it in, but our developers are actively investigating issue.

@TJ Ballard: Fixing this issue would be really hepful, thanks for update.