Set Members in Struct Does Not Work

For some reason, I cannot figure out a way to add things to an array inside a struct. I’ve tried this way and set array elem and neither work. Am I doing something wrong?

You can use “Make Squadcard” and set item into it accordingly.

I think the problem with your code is that you don’t save the modified struct, you are probably just missing a Set for the variable in which you have the struct you are modifying, just after that set members. Take the out pin and set the original variable with it.

yes it seems exceedingly convoluted, you can probably make it more logical with some more thought

I don’t have everything that goes into the array inside the squad card at this point so I will have to change it later which causes the same issue I’m having now.

The set members in struct is “supposed” to change values by reference.

Well I fixed it like this, even though I find this method to be convoluted and unnecessary, if anyone comes across this in the future.

Trust me, I’ve tried all the other methods and they do not work.

I tried the Set Members in Struct in my own project, with an Integer value, and it works as you intended. The problem might be with a array member. You should make a test isolating only that function and work up from there.

Try in the bug reporting section

Yes I’m using it in multiple place with a single variable but I have not been able to get it to work with arrays.