Download

Set Max Walk Speed not actually setting the max walk speed

This is a problem that should have been easily resolved by the hundreds of search results explaining it. Many of which are in this forum.

Yet, this node is just not working.

I have a simple set up where if a zombieAI actor is within killing range of the player then I want to set the player’s max walk speed to a fraction of its normal value. Kind of like the player is being slowed down by the proximity to an enemy.

I’ve tried this multiple ways, but no matter how I set it up the max walk speed never changes.

Here is a screenshot of my latest attempt.

In this BP I’m calling the player character’s movement component from my zombieAI character blueprint. Everything up to that branch is functioning completely fine, I even have the visual feedback of the True/False paths being taken, however; the max walk speed value never changes!

I also tried setting the max walk speed directly from the character BP and that didn’t work either. I had it set up to respond to a boolean that would set to True if within melee range of an enemy. The boolean would set True, but the downstream “set max walk speed” would still not change.

I even tried a simple “Left Shift” pressed -> set max walk speed, but that didn’t work either.

Does anyone have any insight on this?

Thanks.

Try casting to your character and setting the variable. I had done this before, although not exactly the same:

Thanks for the suggestion. This ended up working for me.