Set max jump count when player enter trigger box

Im having some issues trying to get this to work. I included a picture of what I have so far. btw this was done in the level blueprint.

That looks ok, what’s the problem.


For some reason it just doesn’t work. In the third person bp I have the max jump count set to 2. But when ever I try and set it to 1 when the actor begins overlap i can still double jump.

I can hardly see any code, so it’s hard to say. But I would say, always set it to 1 on begin overlap, and only set it back to 2 on end overlap.

All the other code doesn’t have anything to do with the player max jump. I tried setting it to the end overlap but still it doesn’t do anything.

On tick, print the value of max jump. Then you get to see when it’s changing…

I Acually figured it out, the cast of the third person character was connected through the overlapped actor, but I tried connecting it to the other actor and it worked!

1 Like