Set Material(Translucent) Doesn't render properly until I poke the actor

Hi Guys!

I’m trying to set the material of some static meshes through blueprints using a simple create dynamic material instance but I’m running into some issues when the material applied is translucent.

The material should look like this:


But when I set the material during play it looks like this:


Note that The same issue occur even outside PIE but I can get around it by simply ‘poking’ the actor by moving it for example. After that it renders properly and The material is finally translucent.

Also another odd behaviour:
If I load my level and make a copy of any of the static meshes in it and then Applied the material to the copy, it works straight away but if I apply the material to a mesh that was loaded in with the level I have to poke it first.

I couldn’t find any similar issue in the database so I thought maybe I was missing something.

Any help is much appreciated.

Nevermind! A restart of the editor fixed it.

I run into the same issue. Found that when I’m rebuilding lightning it shows grey texture, but if I’m making any action which you called “poke” transparent texture works is rendered fine. Does restarting editor fixed your issue?