Set Invisible Mesh as Master Pose Component (for skeletal Animation)

I have a root skeletal mesh (let’s call it Peter) using AnimGraph blueprint, and multiple meshes connected to that animation by “Set Master Pose Component”, but once i set Peter’s visibility to false, all the connected meshes stop animating. (they resume if i set visibility to true again)

I need Peter invisible but i want the animation to continue. How can i force the animation trough invisibility?

bumpy please

hi does set “hidden in game” work?

hope this helps
Katuta

Very old thread, but just for anyone who comes across it, if you set “Visibility Based Anim Tick Option” to “Always Tick Pose and Refresh Bones” on the mesh component that you want to be the master, it should work.

Although I haven’t yet figured out the performance penalty for this, and am still eager to know if there’s a better solution

image