Set Input Mode Game Only causes a stack overflow when called from an action binding invoked by gamepad input when "Route 1st Gamepad to 2nd Client" is enabled

My play options are set to ‘Selected Viewport’ (though it happens with ‘create new editor window’ as well) and I am playing with 2 players, one being the listen server.
The gamepad I am using is an Xbox 360 wired controller.

When the Set Input Mode Game Only node is called from an action binding invoked by game pad input it will cause a stack overflow (see call stack [here][1]). The node doesn’t have to be called directly from the binding. It happens regardless so long that the stack originates from that binding (I originally found the issue when it was being called from a function in another object).

This does not happen with a single player, or if Route 1st Gamepad to 2nd Client is disabled. It will also not happen if the action binding is invoked from keyboard input.

I was able to reproduce this within my own project as well as in a blank project.

Note: when it crashes no crash report will be generated. I was only able to see the callstack by running the editor through visual studio.

Steps to reproduce:

  1. Create an action binding with a gamepad button mapped to it.
  2. Bind a callback/Create the corresponding input node and call Set Input Mode Game Only. I tried it in both a Character BP and Player Controller and it happened both times, so where it’s called doesn’t seem to matter.
  3. Under Editor Preferences → Level Editor → Play → Multiplayer Options set Route 1st Gamepad to 2nd Client to true.
  4. From the Play button’s dropdown menu select either “[Selected Viewport][2]” or “[New Editor Window][6]”. Note: The callstacks are slightly different for each (see attachments or click the hyperlinks).
  5. Press Play and focus one of the viewports (doesn’t matter which) then press the gamepad input bound to the action binding.
  6. Observe the editor hang then eventually crash with no crash report or useful logs (unless you’re running from VS).




Hello tstaples,

I tried to reproduce this issue in bot 4.11.2 and 4.12.3. I was able to reproduce this issue in 4.11.2, however I was not able to reproduce this issue in the latest version of the engine. It appears that this issue has been resolved in the latest release of the engine. Thank you for your time and information.

Make it a great day