"Set Frame Rate Limit" Affecting Editor

Hello, I’m having problems trying to set max FPS on a widget like this:

Actually works for me but the problem is that it also applies to the editor and I only want that apply it on game. I’m new at UE and its possible I do something wrong.

Thanks for taking the time ro ready my question.
Cheers.

Anybody can help me with this please?

I would reccoment to not use the direct Node to change FPS Cap in the GameUserSettings.

Try it with the Execute Command Line:
“t.MaxFPS N”
Where ‘N’ is your FPS Cap.

And just save/load your own Savegame Config File.

And do not put this into a Construct Function.
Better execute this in the GameInstance Init Event.

Hi! Thanks alot for taking the time of answering my question.

I’m new at Unreal so can you please be more detail with me please?
What do you mean with “GameInstance Init Event”?

I tried to use console to cap FPS with “execute console command” on BP but when I press F11 on the game, the FPS goes to infinite and removes the cap.

Cheers!

Any idea?

Not really, since this probpem is not appearing on my side…
Setting the fps Cap with “t.maxFPS 60” works here for ingqme only… My editor has still unlimited frames

Hey Patrick, thanks for the answer.

The problem with me is that “Set Frame Rate” Blueprint also affects my editor when I set it on the construct widget.

And when I use the console command it works but when I switch in-game from Fullscreen to window mode and then Fullscreen the cap stop working.

If anybody have an idea I will really appreciate the help.

Maybe it’s a Unreal 5.0.2 Bug.

Cheers!