Set Focus / Focal Point in AI Blueprint Not Working

Firstly, I’m asking Focus / Focal Point as I have tried both, I’m not trying to set them at the same time. I’m trying to use set focus / focal point in an AI tree task. I know that the blackboard variable is set correctly as I can print the location string, and my task is very simple and I can confirm its trying to set focus / focal point and no other tasks are running. However my controlled Owner Actor does not look at the Focus Point and rotation is not effected. I also tried turning off Orient Rotation to Movement and this didn’t have an effect. Any ideas what I could look into or am doing wrong?

Reparenting the AICharacter To the (Character) class fixxed the issue


Sorry for being TOOOOOO late. But in case there are users facing the same problem, I’ll just make my answer here.
Edit your AICharacter:

  1. make sure “Orient Rotation to Movement” is unchecked;
  2. check “Use Controller Desired Rotation” in the CharacterMovementComponent or “Use Controller Rotation Yaw” in the Class Defaults.