Set Focus dosent seem to work with root-motion

I cant get Set Focus-node to have any effect in 4.12 if animation blueprint is using root motion only. Set Focus still worked in some earlier build (4.10 or 4.9). Would need it to rotate Ai character at target while using walking animation (using Mocap zombie anims).

I have tried to enable “Use Controller Desired Rotation” and disable “Orient Rotation to Movement” (also vice versa). Use Controller Rotation Yaw is disabled (also tried with enabled). I have tried to enable/disable “Set Control Rotation from Pawn Orientation” in AI controller (parent is detour crowd crowd AIController).

I have debug arrow drawn to show the controller rotation, it always points forward (related to controlled character) even it should turn at target and AI can only move forward.

Have had setrotation loop replacing the set focus node, but worried that takes more performance budjet away than Set Focus would.

EDIT: Set Controller Rotation works, but “Use Controller Desired Rotation” still have no effect. Have tried with rotation yaw rates 360 and 2000.

Hey SaOk,

Sorry for the delay. I am investigating this issue now and will get back to you as soon as I have new information.

Thank you for your patience.

No worries. Thanks for looking into it. Currently I cant find a way to make character with root motion only animBlueprint, to rotate at location or actor without using setrotation nodes.

I apologize for the delay. After some additional testing, I used the Root Motion BP example from the Animation map of the Content Examples project as my AI Character, I was unable to reproduce the issue.

My setup simply consists of Tick->Get AI Controller->Set Focus to my player character.

With this setup, the focus is being set as expected. Could you provide a bit more information regarding how you have yours set up? Screenshots would be great if you could provide some.

Strange, also working for me in that content examples project. But some reason the zombie anims dosent in my main Project. Settings look the same. I need to continue searching why it happens. I let you know if finding something.

Seems like the MoCap rootmotion animations somehow dosent allow setfocus command to rotate the AI character. Could it be possible? I made very basic setup with test AI Character and rootmotion animblueprint and set focus just dont have any effect when using MoCap zombie anims.

Since you were able to recreate this with a basic setup, would you be able to zip up the project and provide me with a link to Dropbox or Google Drive so I can download it? You can PM me the link on the forums:

I made separate test Project and for some reason the setfocus now works in it. So I have something wrong in my end. I will need to keep looking what is causing the issue.

Okay, in the meantime I’m going to mark the topic as resolved. If you are able to determine the cause of the issue, or require further assistance, please feel free to reopen this thread with a comment.

Have a great day

I found out “Use Controller Rotation Yaw” needs to be enabled. Still strange it says it only have effect if using PlayerController.

Had tested it enabled earlier too but somehow hassled to get right results.

Hi, I reproduced the bug. If using the “Use Controller Rotation Yaw”, the actor use set focus correctly to rotate at wanted target. But as downside the rotation happens instantly. I want to use “Use Controller Desider Rotation”-setting to make it smooth. But cant find a way to make that setting work, nothing happens when its enabled. The actor just walks straight when “Use Controller Rotation Yaw” is set off. If its on then the rotation is instant. Sending repro Project in PM.

Hey SaOk,

I’ve found a way to get the results you’re looking for. The behavior you were experiencing was working as intended. But here, I disabled Use Controller Rotation Yaw as well as Use Controller Desired Rotation and did this instead of the Set Focus that you initially had:

With this setup, it was working great on my end.