Set Editor Property Doesn't Work Instance Material


Using “Set Editor Property” when casting to a Instance Material only works when populating the “Parent” field. But does not set any of the variables added from the Parent field.

As you can see I have a Property Name “Switch Base Color”, but it does not enable or successfully connect to my “Set Editor Property”. I have tried alternative names a well, such as “SwitchBaseColor”, “switchbasecolor”, etc. Image example below. I have also tried to save the asset and reload it. Still doesn’t work.

For some reason I don’t have access to such a node at all, that’s odd.

But that’s not the point. The point is, static bool parameters are, as the name suggests, static. You can’t change them via blueprints, AFAIC.

Hi Tuerer,

This is part of the Asset Tools and are used to directly modify the Editor. It’s not for game Runtime. Thus, the “Make Literal Bool” operation should change the value. Even if I didn’t use a Bool as an example and just changed a texture map, I get the same results. It fails to update the texture.

I also would like to note I do not have this issue with modifying a “Material” only an “Instance Material”.