Set Custom Depth during gameplay does not lead to outlines appearing

I have a working outline setup that makes custom depth objects create outlines around them. I want to toggle this however on a per object basis (gameplay highlighting of objects under crosshair), but when I do Set Custom Depth in BP, the outline does not appear/disappear.

The property is changed, as I can do Get and I see the correct True/False, but the view does not show so. I assume the post processing only initiates once and then does not check for this again or such, but is there any way this can be done/fixed?

Thank you for bringing this to our attention. This does appear to be a flaw in the system. We have entered a ttp and our rendering engineers will work to fix the issue. Martin Mittring is on this thread and should be able to update you as to when the problem will be resolved.

This is fixed in latest code and should make it into the next or latest the one after next Rocket release.

I still have this bug on 4.4.1

I have a blueprint for setting custom depth of a skeletalMesh to true, it compiles and the detail panel says I am rendering the mesh with custom depth on, but the outline just won’t show up.

The problem was fixed by adding another BP function that switches the material to something else(in my case a placeholder material instance). My guess is it still does not update things correctly, and everything that resets the rendering property for the mesh will fix the problem.