Set Anim Instance Class not working anymore

Using 4.22.3

I’m currently working on a project that requires switching between weapons and associated animations. I opted to switch anim instances on change, partially for sanity’s sake, but also because it’s worked in previous projects. Unfortunately, on this new project, switching the anim instance causes a few problems.

First of all, the character’s mesh bunches up at the origin/root bone of the character. Second, all of my secondary meshes (which use the character’s base mesh as a master pose component), kinda sorta t-poses? It shows in t-pose but everything’s moving/jiggling so fast it just shows up as a blurry mess.

Thinking I’d done something wrong, I checked out a tutorial about switching anim instances. The tutorial calls the change from the anim blueprint, but doing this in my case just crashes the editor outright.

Another thing I tried was just to create an empty ABP for testing purposes and switch to that, thinking that all the uber-ridonculous stuff I had in the others might be part of the issue. It wasn’t. Result was the same.

I really don’t understand why this method (switching anim instance class) would work in one project, but not in this one. I’m guessing it’s something stupid I’m missing or done, but for the life of me I can’t figure out what.

Anyone else having/had this problem?

So I eventually ‘solved’ this using Sub Anim Instances. However there were some caveats I wasn’t prepared for, primarily that SAI’s don’t propagate ‘play montage’ or fire notify events to the parent. All of that functionality had to be moved to the ‘parent’ ABP, which while feeling kinda cludgey imo, felt less hacky than trying to get Set Anim Instance to work.

Still confused why Set Anim Instance still works in my original project and not this one, but what’re ya gonna do?