Download

Set actor mesh to collide with projectiles but not block pawns

I’m having trouble with this. If i set bBlockActors to false, it will no longer collide with projectiles.

Anyone know what i’m missing here? Cheers

The physics and collision settings never seemed to work as expected for me. My suggestion would be to brute force all the possibilities and see if any of them work. You can do that by setting up a function triggered from Kismet when your pawn steps into a box. Inside the box is your actor that shouldn’t block pawns. Print out the current settings, fire a projectile, see if your pawn is blocked. Make the function change the collision settings and do it again.

I managed to get it to work using bProjTarget=true. However this is a bit of a hack, as this is not what this param is meant for.