ServerTravel, out of date NetDriver?

Hi,
I’m not sure if this is a bug or if I’m doing something wrong but here is my problem:

When I server travel (non-seamless), this log is printed continuously on the client side during the travel:

LogWorld:Warning: SetActiveLevelCollection attempted to use an out of date NetDriver: GameNetDriver

Here is the full log (I think I call ServerTravel at line 91): LogTemp: Repeting last play command: Selected ViewportLogPlayLevel: PlayLevel: - Pastebin.com

I am using SubSystemNull.

Does anyone knows what this log means ? I can’t find any information about this on google.

Thanks.

EDIT: I just tried traveling with the console command in a new empty c++ project and got the same thing, here is the log : LogPlatformFile: Not using cached read wrapperLogInit:Display: RandInit(120633 - Pastebin.com

I’m seeing this as well

“LogWorld:Warning: SetActiveLevelCollection attempted to use an out of date NetDriver: GameNetDriver”

Any update on this? Same problem here

Getting the same thing here

Do you try to connent from one PIE Session to another? https://answers.unrealengine.com/questions/700326/client-connection-with-invalid-version.html

Yes I did, seems odd. As it used to work fine!

Any progress with this?

Does someone solved anyway?

I’m having the same problem.

SetActiveLevelCollection attempted to use an out of date NetDriver: GameNetDriver

same here in 4.18, anyone solved it?

One possible solution, if you are using the Steam online subsystem, is to enable seamless travel and setup whatever code/bps you need to make that work. I found out that steam does not support server travel calls without seamless travel enabled and the error is exactly the same. Another thing to be aware of is that seamless travel currently doesn’t work in PIE. I’m not 100% sure, but I saw a support request on the oculus dev site that mentions this same error, so it’s possible that the same restriction applies to the oculus online subsystem.

I believe this is the correct answer. We are still trying to get our stuff working but the basic connections seem to function through steam using seamless.

I’m also getting this same problem on 4.18.0 on a project that used to work on UE 4.15. Apparently, this error arises because a chunk of code marked with “TODO: START TEMP FIX FOR UE-42508” (World.cpp - line 6419), as far as i could debug it, the netdriver was ok before this, and would be working if the temp fix hadn’t been applied. I’m not using steam subsystem, just trying to connect two machines through PIE.

Still facing this.

Still experiencing this in 4.21. Couldn’t find anything online about how to fix.

4.22 still an issue being ignored…

On a side note: Don’t use special characters in replicated variable names! I learned this the hard way! (I think it was either a " " or “_” that caused me issues. Took FOREVER to debug. xD

If this doesn’t work for you, make sure to do the following:

In your “Open Level” node after hosting the session, make sure you put “listen” in the options.

To add to this:

  • Make sure AGameModeBase::bUseSeamlessTravel is set to true
  • Make sure a transition map has been set in the project settings.

Can someone explain just a bit more?
Do I understand it correctly, that for steam seamless travel is mandatory? If not, you will have problems on server travel? And is this still valid?

I read about server travel ( Travelling in Multiplayer | Unreal Engine Documentation ) but I am wondering about about how to work with it in my everyday scenario. I test a lot in PIE Tests before testing in stand alone. This means I can not test lobby and such things anymore in PIE right?

At the moment I have Lobby-Player-Controller and Lobby-GameMode splitt from “game” Player-Controller and “game” GameMode. Is it possible to use servertravel but also generate new GameMode, the one which is assigned to the map?