Servertravel crashes editor

Crashing when I try to exequte console command servertravel in blueprint. Everything worked fine but today I had some experiments with my project. Didn’t make test play for a while and can’t say when it started to happen.
Please help.


Are you using 4.10.4? If not, go ahead and update your engine version and give it another shot. This seems related to UE-27124, which is a crash related to switching levels, and was reported as fixed in 4.10.4.

  • Have you been able to narrow down steps to reproduce this issue in a clean project?
  • Have you attempted to do the same thing in the 4.11 preview to see if it crashes there as well?
  • Could you provide the logs from your project’s Saved->Logs folder after the crash occurs?

This entire project was made in 4.10.4 version. I had some troubles with updating project to 4.10 and decided to recreate it in new version.

  • Yeah, first of all I downgraded my project to it working state. It doesn’t help :frowning: But I am not sure about 1 thing. One of last things I created was a new game state and had some experiments with timers. When I got this troubles I tried to remove this game state and got some weird “cast failed” errors on compiling widget blueprint that displays timer to player. I dont know why, cause I removed everything connected to game state bp. Reloaded my project and this problem disappeared. Well now I don’t understand what is going on at all.
  • No I have no 4.11. My internet connection sucks and currently I am stuck with 4.10
  • Yes but later a bit. Rightnow I have no access to my home pc.

Please let me know when you get the logs uploaded.

I’d like you to attempt a test when you have a minute.

  • Create a new, blank project.
  • Create 2 maps (Map 1 and Map 2).
  • Open Map 1.
  • PIE
  • Open the console using the ~ key.
  • Type Open Map2 and press enter
  • After the transition completes, open the console again and type Open Map1

Let me know if this causes the project to crash for you.

Just made an expected crash and this log generated. link text

Made a test with 2 maps. Everything works fine.

Btw, in the previous project servertravel works fine. Just checked out.

Well, at this point I have no idea. Rightnow I am trying to recreate whole project by simple copypasting blueprint contents.

If the server travel seems to be working, what changes did you make to the project before it began crashing? We’ll need to attempt to identify what steps are causing the crash.

Okay, with this method, the best thing to do would be to compile and play after you add each blueprint back into the new project. That way you can tell exactly which blueprint is causing the project to crash. If you discover this, please let me know which blueprint is causing the issue, and provide a screenshot of that blueprint.

Ok. I recreated my project and everything works fine. It is literally clone of my bugged project. I have no idea what gone wrong. Well, I can archive unpacked project and upload it somwhere if you want to find out what is going on.


It’s possible that some of the assets became corrupted, and recreating them solved your issue. If this issue comes back at any point, please feel free to reopen this thread. For now, I will be marking this topic as resolved, as recreating your project seems to have fixed your crash.

Have a great day