Server Error: TravelFailure: ClientTravelFailure, Reason for Failure: 'Servers can't open network URLs'

So I’ve seen a few posts like this but no one has an answer yet and they keep getting marked as answered
I followed this guide to a T. A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums
Did it twice, using Community 2015 Update 3 and UE4.18 RUNNING ON LOCALHOST TO TEST using the FirstPersonExampleMap as the main map.

Heres my log: link text

This is a new one for me. It looks like you should branch on “IsLocallyControlled” to make sure it’s not running on a server or a non-owning client. The client can open a URL like that but a server cannot.

The engine code involved is UEngine::Browse(). It’s in Engine\Source\Runtime\Engine\Private\UnrealEngine.cpp.

I mean I’ll try taking a look.

I mean i found the code snippet that logs Browse: URL to String but not the isLocallyControlled variable

It isn’t a variable. It’s a function. It returns true if it is called on a local client. You want to check that and if it is true then you should open the URL. If it is false then do nothing.

I was only giving you a reference to the code involved in case it helped. There’s nothing there that you need if I’m right. But if I’m wrong, you have a place to look.

isLocallyControlled isnt a function in that file hmm
A search shows it in these directories

but it seems to be affecting control of characters not client/server

It’s called from the pawn. If you are doing something different then I need more context. What is happening when this problem occurs? If you can show some code that would help a lot.

So you are specifically at this step? 3. Launch and test the server

The more information you give, the easier it is for us to help you.

Are you running it with any command line parameters?

In Project Settings → Maps and Modes, what is “Server Default Map” set to?

The error implies that somehow you are telling the server to open a URL. It also implies that this is not allowed. So we need to figure out where and how this URL is being given to the server – because it is not normal.

Happy to work with ya.
I have it set to my map which is cleverly named FirstPersonExampleMap

there are no command line parameters being run. everything is build and the builds have been successful.

OK. The log file says this “Browse:”. You need to get rid of that “” so it says “Browse: /Game/Maps/FirstPersonExampleMap”. Basically, you shouldn’t be giving the server the IP address like that. It will bind to by default. However that is getting into the mix, get it out.

I get that. I’m only following the instructions to start a dedicated server

More than happy to provide answers. And yep right at step 3.

Roger that. I have an idea perhaps. The only place i set is this step

  1. Prepare the project for packaging

So i might try removing that…?

Yeah. You can’t run that on the server for sure.

And make sure when you do connect that it’s happening on a client and not on a server. Easiest thing for now is to just connect the clients using the console command (the ` key brings up the console in a Development build). The command is “open”. Once you get settled you can have the clients use the “ExecuteConsoleCommand” node and connect automatically.

Right now im executing another build using the tutorial. if it still fails i’ll try removing that node. but i wanted to try a clean game again. I’ll post the results of both once im done

Doing a clean build worked.However when clicking the project.exe I dont get the Join succeeded message

I get all the way to here: Screenshot - 6a9624348f3a982ace9322c44173a758 - Gyazo
which is good
No error this time but its just a black screen. They did have me delete the player start capsule and set the default map to the testLevel.

The thing is, when i click I hear the actions of my game, but see nothing. Just a black screen and no server log for a successful login.

Solved that using your method of using ` open

The connection looks like it’s good. It seems the problem is the client is using the Entry map, not the map you want it to. In the Maps & Modes section of Project Settings, there is a spot called “Game Default Map”. If it’s not already, set that to the same map as “Server Default Map”.