Serious problems packaging in 4.19

Dear Unreal Engine community,

Sadly I decided this weekend to sync my Unreal Engine (compiled from source version) to the latest, from 4.18.3 to 4.19.2. Since I did the merge, I have been running into multiple issues with packaging for iOS. I’m hoping I’ll be able to tap into this community awesomeness to save my skin.

My setup: I run UE4 on a PC, in a version compiled from source, using VS 2017. To compile for iOS I run a Mac OS Sierra on a virtual machine (Virtual Box). Despite some difficulties in setting this up, this setup has been running smoothly for a long time.

After I synced my UE4 to 4.19.2 (from 4.18.3) these issues started to happen:
Issue 1: rsync error - I have no idea what the error is and it refers to some previous errors which aren’t there.

    UATHelper: Packaging (iOS):   rsync error: some files/attrs were not transferred (see previous errors) (code 23) at /home/lapo/packaging/rsync-3.0.4-1/src/rsync-3.0.4/main.c(1040) [sender=3.0.4]
    PackagingResults: Error: some files/attrs were not transferred (see previous errors) (code 23) at /home/lapo/packaging/rsync-3.0.4-1/src/rsync-3.0.4/main.c(1040) [sender=3.0.4]

Issue 2: identifiers not declared. These errors happen consistently across various modules, and I don’t know how to solve it.

PackagingResults: Error: C++ requires a type specifier for all declarations
PackagingResults: Error: expected expression
PackagingResults: Error: use of undeclared identifier 'GPU'

I genuinely don’t understand how these packaging errors are happening since I’m using a clean github copy of UE4. So far I have tried a few things:

  • Deleted all project folders other than “Content”, “Config” and the actual uproject file - no use
  • Recreated and updated the Mobile certificate - no use
  • Tried to “compile” and “build” in UE4 - all run smoothly - no use
  • Cry, pray, implore for a greater power to intervene and make it work - no use

I know somewhere in this community there is a guru who, differently from me, actually knows what he/she is doing. If that is you and you could help me with this issue I would be eternally grateful.

Kind regards,

Hello Al Ananias, I’ve had the same problem, but finally i resolved it just now.

On your mac, plz delete the following directory(it’s for remote compile).

I guess there’re some garbage of old version(maybe 4.18.3) ue4 editor.

1.ROOT\UE4\Builds"Your PC(not Mac) User ID"\C\Users"Your PC(not Mac) User ID"\Documents

2.ROOT\UE4\Builds"Your PC(not Mac) User ID"\C\Users"Your PC(not Mac) User ID"\Downloads

I hope it helps you.

Thanks Riv. I ended up reinstalling the whole thing and it solved the problem somehow. Maybe that folder got deleted in the reinstall so your solution might have been the answer.

Thanks again