Serious problem with multithreaded GC


I recently upgraded to 4.26 Release and found that my Android game started to crash very often.
i spent 2 days in discovering the problem, looking for a solution in the forums, but found nothing.
As a result, I tried to change the GC settings and the problem went away.

At the time of starting the game or when “OpenLevel”, a crash occurs. It is very difficult to catch, because it does not happen every time, but about 1 \ 10.
I have not been able to determine what exactly this is due to. i tried a lot of options, thinking that the problem is in my game, but no.

I will attach all the error data that I was able to get. I’m sure this is due to multithreaded GC.
In version 4.26, multithreaded GC is enabled by default.

I will also attach the data that I was able to get from the Internet in search of this error.

I am having the exact same issue on Android after engine update to 4.26. Can confirm that setting
gc.AllowParallelGC=False in AndroidEngine.ini hotfixes the problem.