Serious difficulties building from source

Hey everyone,

I’m trying to build from source to try Chaos Destruction. I’m a developer by trade (not in game development), so I’m not exactly entirely green when it comes to build issues. However, I’ve tried everything I can think of, and I’m now roughly ten hours into trying to figure this out.

I’ve tried with the current “release” branch, the 4.25 branch, and the 4.24 branch. Git pulls and tarball downloads. I’m on Windows 10, 64-bit.

I first tried VS2019. I know now this was a mistake - a lot of the articles I came across blamed VS2019 for directory and intellisense issues. Most of these builds didn’t even complete. I moved to 2017, and managed to get most builds to completion.

The first several builds would result in memory access violations, in seemingly random places. Debug information was all over the place, and most articles were surrounding projects not compiling, not the editor itself.

I then uninstalled every visual studio I had on my system (2013, 2017 and 2019), as well as manually uninstalling .net SDK’s and Windows SDK’s. I then installed 2017 with minimal packages (C++ game development and Unreal).

My latest build of 4.24 with Chaos will start if I open it in VS, and allow me to create a project. Opening said project then exits the process in VS, and opens a standalone version. This inevitably fails, as does just trying to open the executable on its own (just to get to the project dialog.)

This is the error message that I’m getting when running the executable outside of VS, that as far as I can tell, I’m the first person to ever see:


The only other information I have that may or may not be worth mentioning, is that when I start the editor through VS, I receive 3 breakpoints that can be stepped through. All are of the type Shader type was loaded after engine init, use ELoadingPhase::PostConfigInit on your module to cause it to load earlier. The first two are in UE4Editor-HoloLensAR.dll, first dynamic initializer for ‘FHoloLensCameraImageConverionModuleVS::StaticType’, and the second for dynamic initializer for ‘FHoloLensCameraImageConverionModulePS::StaticType’. The third is in UE4Editor-WindowsMixedRealityHMD.dll for dynamic initializer for ‘FDepthConversionPS::StaticType’.

I also have SteamVR installed, which opens every time I open the editor. I only mention this because 1. The breakpoints that show up relate to VR, and 2. SteamVR does attempt to open the UE4Editor in it (if I’m wearing my HMD when I start the editor, it says “UE4Editor” is next up.)
If it matters at all, headset is a Valve Index, RTX 2080TI, I9 9900K, 32GB RAM

Does anyone have any insight? I’m starting to pull my hair out over this. I feel like I must be missing something obvious, but I’ve followed every tutorial to the letter.

Thank you in advance!

I’m getting the exact same errors trying to start 4.25 with Chaos - the same 3 exceptions on startup, and the same crash when I try to create a project:

Fatal error: [File:D:/GitHub/UnrealEngine/Engine/Source/Runtime/Core/Private/Logging/LogSuppressionInterface.cpp] [Line: 444] Log suppression category LogMrMesh was somehow declared twice with the same data.

I’m using a clean install of VS 2019. I do not have SteamVR installed.

Same here… Have SteamVR installed. Running VS 2017

Tried to disable the Hololens modules/plugins by removing the Modules in the .uplugin files.
I even renamed the “\Engine\Plugins\Runtime\AR\Microsoft\HoloLensAR” folder so I hoped it wouldn’t try to load the shaderType, but without success.

It still tries to load the shaderType:

0x00007ff904336510 {UE4Editor-HoloLensAR.dll!FGlobalShaderType FHoloLensCameraImageConversionVS::StaticType} {…}

I’m not sure how to prevent this…

I do not need VR (or hololens) support for my “experiment” :).

The fix for this ended up being detailed in another thread about the same issue, here:…ta#post1763850

Specifically the forum thread for how to enable chaos, which is what you should follow, here:…o-enable-chaos. The official documentation is incorrect.