Serialization Error won't let me open the editor

I am on Unreal version 5.0.2, and when I try to open my project, I get an error saying:

Serialization Error: Action Needed
Corrupt data found, please verify your installation.

I tried verifying my Unreal Engine installation, and that didn’t work. Also, I can open other projects perfectly fine, but this one won’t work.

Does anyone know why this is happening and what I can do to fix it?

Hi man ,
if you can open other project i think its a problem specific to this project.

I would suggest you to delete some folders and try again , and if nothing work ,
maybe you can make a new clean project and copy there your “Content” folder.
Be sure to use tha same engine you were using , otherwise dont work.

But before, as already said, delete all but the uproject file, tha content folder and the config folder.

Saved ,intermediate, derived data cache , builds , Folders can be deleted
But you will have to recompile all the shaderss

I know this is old, I have searched many of these same threads to figure my problem with this error, maybe this can help someone in the future. (I am using UE5.0.03 as of now)

Not sure what I did, but one of my UMG’s were corrupted, did many of the suggestions elsewhere, nothing worked…

Then I did some digging,

in the project folder for your game, look in the “saved” folder
then open the .log
then scroll through and see what may have been causing the error
(in my case,
[2023.03.07-04.05.43:484][ 0]LogLinker: Error: Invalid export object index=123391 while reading /Game/Widgets/MainPages_WD. File is most likely corrupted. Please verify your installation.
[2023.03.07-04.05.42:535][ 0]LogProperty: Error: FStructProperty::e oSerialize Loading: Property ‘StructProperty /Game/Widgets/MainPages_WD.MainPages_WD_C:Source Button Info’. Unknown structure.
[2023.03.07-04.07.22:383][ 0]LogWindows: Error: Assertion failed: false [File:D:\build++UE5\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\LinkerLoad.cpp] [Line: 5376])
Also, UMG error popped up a few times in the log.

/Game/Widgets/MainPages_WD is what told me where to start.

So, the only way I found to open the project up through UE, was to go into the project folder, content folder, and then look for ueasset in which ever folder it was located in.
Right click it, “Open with” UnrealEditor.

As it loads, it gave a warning/error message that had button options to continue or exit. (If that is what it said). Click on Continue.

Then, you should be able to open the project without problem…just don’t try to play it or open anything inside just yet.

**Now, let’s move back in time. Inside the project folder, locate the corrupted file → Copy it → Save it somewhere for temp → DELETE the file from the Project Folder. I restarted the whole engine to be safe. And after all this, I was able to edit through all my project files again inside of UE itself, also OPEN it without the corruption error popping up.
Go through all the files that need to be compiled, unplug any pins or undo anything that had to do with the corrupted file.


Now that it should be working normal again, go to where you saved that corrupt file → COPY it → PASTE it back where it was originally at inside of the Contents folder or the project.

Now the “corrupt” file will ask to import (atleast it asked me), accept whatever it asks you, and it may ask to undo/redo any unknown or broken stuff. ACCEPT that offer.

Now, finally that corrupted file should be working again. Just go back and re-plug any nodes pertaining to that file.

Sorry for the long write, but it was the process that saved me 3 weeks of progress on a game that I actually put thought and work into, to make a complete working game, not just a test project.
Again, sorry for all the “thens” and “also” haha. But, hopefully this may be able to help someone else from here on out with a similar case.

1 Like

Oh My God! I almost ready to redo a 20 days super much work without backup (just as you), now it works , thanks a lot sir. :slight_smile: