Download

Sequencer

I have a character, that has the additional geometry (armour, clothing) and this extra is attached to the main skeletal mesh through the Character Blueprint (Construction Script -> Set Master Pose Component). In version 4.14 I could use such character in the Sequencer. In version 4.15, and 4.16.0 (preview 1) - no. Because additional parts do not move after the main skeletal mesh as before, and stand still (in Sequencer). Of course, there is a simple solution - use a single-piece structure, import the character along with individual parts as a whole. But I would like to have the ability of customization.

I have just read the documentation, but didn’t found any special recommendations or restrictions. What blueprint will work in the sequencer, and which are not. Didn’t found an answer why “Set Master Pose Component” worked in 4.14-Sequencer, but stopped working in 4.15 and 4.16.0 (preview 1).

I really like the sequencer and its new features, but I don’t know what to do next. To remake all of my characters. Or are there other, newer methods for attaching additional parts to the main skeletal mesh. Which will work correctly in the new versions of the Sequencer.

4.15 allows you to use ‘sockets’ inside of each skeletal bones, which can be used the way you have described.

Does it not work when scrubbing but in PIE? Or just it doesn’t work in both?

It doesn’t work in all cases: when I just move the slider and when I press play in cinematic sequencer window.

I tried doing characters with a simple actor blueprint (not the character blueprint as before) - the result was the same. “Set Master Pose Component” works great if I just start the game level (the character, clothes and all extra parts are moving synchronously), but it completely breaks down in the sequencer (only the character is moving, i.e. the main skeletal mesh. other parts that share the same skeletal mesh, do not inherit the animation).

I made a simple project-demonstration (link). Here’s how it looks in 4.14.3

035cf2a8c37cf69aedafd9663fe227675666be2a.jpeg

and in versions 4.15 and 4.16

edit: fixed the link

I can’t seem to download from the link. It says the key is invalid.

It seems to be working in 4.16 at least, the golden thing followed the mesh. Both when playing the sequence in begin play or whatever or when rendering the sequence to an image sequence.

The link has a <br> tag which you need to remove to download the project.

Edit: It is not attached when piloting the camera in the viewport though, is this the issue?

I don’t understand, on my computer the golden thing (extra part) does not follow the character in the 4.15/16-sequencer (as on the second picture I uploaded) (( May be something wrong with my computer or the engine was not installed correctly? I also noticed that the render works weird: no character (and extra part) at all in the video (4.16.0). And the engine is periodically crashing when rendering. But all works perfectly in 4.14. Maybe the problem is that I have all three versions of the engine? I’m stumped ((

@cyaoeu Thanks for the tip on downloading.

I looked into it, and it is issue with viewport. If you do PIE, it works fine. (you can add to level sequence and do PIE with auto play)

I added ticket for 4.16 and we’ll fix it.

Thanks,

–Lina,

You need to tick Show Character in the sequence render options. But you can test putting create level sequence in the level blueprint on begin play or something, it should work. As Lina said it’s just not showing up correctly in the viewport. If you’re experiencing crashes you should send reports so they get fixed.

Thank you cyaoeu, Lina :o this is the end of my suffering )) I don’t need to remake all my characters :smiley: