Sequencer: Transform not updating when making changes

I’m using the sequencer to block out my gameplay/intro. I’ve added some static meshes to the sequencer. The only track I have in the sequencer for these objects is “visibility”.

When I now close the sequencer, change the transform of these items (rotation, location, scale, or a combination) then reopen the sequencer, all these changes are lost! Closing the sequencer restores the changes again.

Ergo the sequencer is saving transform information even though I specifically told it to only control the visibility.

This appears to be a major bug.

Also in a related issue: when auto-keying using the transform gizmo in the editor viewport works very well, but typing values in manually in the “Actor Details Panel” will not work, the values will reset when changing the time in the sequencer.

Deleting the objects from the sequencer, and then undoing the delete worked as a workaround for me without having to re-key everything.

1 Like

I’m not sure I follow. Can you give me some detailed steps?

Here’s what I did:

  1. Add cube.
  2. Create sequence, add cube to sequence (which creates a transform track). At this point, sequencer has a record of where the pre animated position is so that it can return the cube back to before sequencer takes control of it.
  3. Delete the transform track. At this point, that knowledge of the pre animated position is thrown away because it’s not going to be moving the cube so it doesn’t have to restore its position. This is where I suspect things are hanging on for you.
  4. Close sequencer. The cube stays where it is.
  5. Move the cube in editor.
  6. Open sequencer. The cube stays where it is.
  7. Close sequencer. The cube stays where it is.

Let me know what step I’m missing and I’ll try to help debug. Thanks.

Here’s a clearer step by step list of what happened:

  1. Add a sequence to the level
  2. Add a cube
  3. Add cube to sequencer
  4. Add visibility track to sequencer
  5. Close sequencer
  6. Change transform of cube
  7. Reopen sequencer: notice cube swaps back to old transform

I’m fairly certain the objects in question never had a transform track in the sequencer.

After having used the workaround of re-adding the items to the sequencer by delete-undo, I can’t reproduce the issue any more.

I haven’t been able to repro with your steps either. At step #3 - adding a cube (any static mesh actor) should automatically create a Transform track. Once you have that Transform track, the current position is stored. If you move the cube while sequencer is open (and don’t set any keys), the position will be saved as the default position for that Transform track. If you close sequencer and re-open, that Transform track will evaluate that position again.

If I follow your steps and delete the transform track after step #3, the cube does not swap back to the old transform after step #7 because the transform track doesn’t exist so there’s no stored position.

Let me know if you’re able to repro again.

I tried this, but this might not work anymore. … I am using 5.0.2 version, I have to readd all Blueprint and camera and animate them again when doing sequence.