Sequencer stops playing in the middle of it when it is played via beginplay of the level

Hi

I have a five minutes sequencer, it is played well with auto play but when it is played on beginplay of the level BP it’ll stop after one minute.

I don’t know how to access to its logs

Hey saeedc,

I’m not seeing this on my end. Do you have a camera cut track in your sequence and does the camera section extend all the way to the End Time?

-Matt W.

yes. camera section extend to the end.

I said it works fine with auto play on.

How can I access to logs related to it?

I did not do any thing complicated only some movements and audios

Window>Developer Tools>Output Log. You can also access them after the fact in Saved/Logs in your project folder.

I tried it last time with both Auto-play and Event BeginPlay. They both worked.

If it isn’t a complex setup for your sequence, could you set it up in an example project and attach it?

-Matt W.

Matt

I reproduced this issue in a different project.

this is a 100 seconds sequencer with a moving cube.

you can see that that cube will stop moving after about one minute and sequencer stops totally

Matt
its file is 18 MB and won’t upload. what to do?

Delete your saved and intermediate folders and zip it up. If it’s still too big, upload to google drive or dropbox and send the link.

link text

I sent it but I am not sure if have done it right

I’ve resolved this by checking the Autoplay under Level Sequencer Actor: Details - Playback

Hey adre.

I have already mentioned in my comments that it works well with auto play on but auto play cannot be a solution for it.

Matt

I am on Win10. 4.12.2 and that was a scalable & mobile project I sent

Adre, he is reporting that BeginPlay doesn’t play the entire sequence, but autoplay works fine.

Right click the folder>Send to>Compressed(Zipped)Folder in windows, then upload the zip file and send me a link to that. I can’t download your link without adding it to my drive, which I can’t do with the permissions on my account.

link text

try this Matt

Hi saeedc,

I was able to track down the cause of the issue, and it appears to be the “Create Level Sequence Player” node. I’m not sure why, but that causes any sequence to stop after 60 seconds. I’ve entered UE-32420 for this bug.

Instead, I would suggest setting it up using a reference to your Level Sequence and using “Get Sequence Player”. This setup allowed me to play any length sequence. I tested a 5 minute sequence this way.

-Matt W.

Thank you Matt.

it worked with Get Sequence Player :))

I’m sorry… I was too excited after struggling with this problem for 2 days. Thanks anyway.

It’s stopping after 60 seconds due to being garbage collected. This stops the camera being updated and the Stop() callback being fired (and presumably any other callbacks too).

The field that remembers the player object needs to be marked as a UPROPERTY(transient) even though it is never editable.

Cheers
John

Im having a similar problem where I have setup a master sequence with multiple cuts and cameras. Basically everything in the cinematic tutorial videos using the infinity blade assets.

Everything seems to play through fine in realtime when I play in the sequencer/cinematic viewport; but when I render to video the animations on the skeletal meshes often freeze and pop back to spawn pose.

Ive tried to look into some of the solutions for the similar problem here but it doesnt work.
Has anyone had this issue or have a solution? Thoughts?

Using a pretty beefy machine and 4.18.2